概述

单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

  • 交换机连接主机的端口为access链路
  • 交换机连接路由器的端口为Trunk链路

缺陷

  • 单臂路由所有的流量都要经过主干链路,流量过大,容易形成流量瓶颈
  • 单臂路由,一旦出现单点故障,对下vlan,所有vlan就不能通信了

拓扑图

  • 路由器的物理接口可以被划分为多个逻辑接口
  • 每个子接口对应一个VLAN网段的网关
    单臂路由.png

配置

AR1

vlan batch 10 20
interface GigabitEthernet0/0/0.1
 dot1q termination vid 10
 ip address 192.168.10.1 255.255.255.0 
 arp broadcast enable

interface GigabitEthernet0/0/0.2
 dot1q termination vid 20
 ip address 192.168.20.1 255.255.255.0 
 arp broadcast enable

LSW1

vlan batch 10 20
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10

interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 20

PC1

  • 路由器GigabitEthernet0/0/0.1子接口IP作为网关
    PC1.png

PC2

  • 路由器GigabitEthernet0/0/0.2子接口IP作为网关
    PC2.png

测试

PC>ping 192.168.20.2

Ping 192.168.20.2: 32 data bytes, Press Ctrl_C to break
Request timeout!
From 192.168.20.2: bytes=32 seq=2 ttl=127 time=78 ms
From 192.168.20.2: bytes=32 seq=3 ttl=127 time=94 ms
From 192.168.20.2: bytes=32 seq=4 ttl=127 time=78 ms
From 192.168.20.2: bytes=32 seq=5 ttl=127 time=78 ms
最后修改:2022 年 11 月 04 日
如果觉得我的文章对你有用,请随意赞赏